9 Comments

  1. Robert

    Does not seem to work on Ubuntu 16. Everthing goes fine until this message et end of running ./configure
    .
    .
    .
    checking for pkg-config… /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0… yes
    checking for JANSSON… yes
    checking for libmicrohttpd… no
    configure: WARNING: libmicrohttpd 0.9.5+ not found; getwork proxy will be unavailable
    checking for libevent… no
    configure: error: Package requirements (libevent >= 2.0.3) were not met:

    No package ‘libevent’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables libevent_CFLAGS
    and libevent_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    root@robertbit:~/bfgminer# make
    make: *** No targets specified and no makefile found. Stop.

  2. SDR

    Hi
    when i send command ./autogen.sh
    configure.ac:35: warning: macro ‘AM_PATH_LIBGCRYPT’ not found in library
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:29: warning: AM_PATH_LIBGCRYPT

    here the complete message
    root@linux:/bin/bfgminer# ./autogen.sh
    Getting submodules…
    Submodule ‘ccan’ (git://git.ozlabs.org/~ccan/ccan) registered for path ‘ccan-upstream’
    Submodule ‘knc-asic’ (git://github.com/KnCMiner/knc-asic) registered for path ‘knc-asic’
    Submodule ‘libbase58’ (git://github.com/luke-jr/libbase58.git) registered for path ‘libbase58’
    Submodule ‘libblkmaker’ (git://github.com/bitcoin/libblkmaker.git) registered for path ‘libblkmaker’
    Cloning into ‘/bin/bfgminer/ccan-upstream’…
    Cloning into ‘/bin/bfgminer/knc-asic’…
    Cloning into ‘/bin/bfgminer/libbase58’…
    Cloning into ‘/bin/bfgminer/libblkmaker’…
    Submodule path ‘ccan-upstream’: checked out ‘8b0bdb090e2882aa431e89f4bc7aa4736e9e2838’
    Submodule path ‘knc-asic’: checked out ‘e75c9ba362466546a83f1e705b62510a0e0afc6c’
    Submodule path ‘libbase58′: checked out ’16c2527608053d2cc2fa05b2e3b5ae96065d1410’
    Submodule path ‘libblkmaker’: checked out ‘d2dde7a9edd4ec0360b82dd70be5586163ac2fe8’
    Running autoreconf -if…
    configure.ac:35: warning: macro ‘AM_PATH_LIBGCRYPT’ not found in library
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, ‘.’.
    libtoolize: copying file ‘./ltmain.sh’
    libtoolize: Consider adding ‘AC_CONFIG_MACRO_DIRS([m4])’ to configure.ac,
    libtoolize: and rerunning libtoolize and aclocal.
    libtoolize: Consider adding ‘-I m4’ to ACLOCAL_AMFLAGS in Makefile.am.
    configure.ac:35: warning: macro ‘AM_PATH_LIBGCRYPT’ not found in library
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:29: warning: AM_PATH_LIBGCRYPT missing; CLI tool will not be available
    configure.ac:17: installing ‘./ar-lib’
    configure.ac:16: installing ‘./compile’
    configure.ac:18: installing ‘./config.guess’
    configure.ac:18: installing ‘./config.sub’
    configure.ac:13: installing ‘./install-sh’
    configure.ac:13: installing ‘./missing’
    Makefile.am: installing ‘./depcomp’
    parallel-tests: installing ‘./test-driver’
    libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, ‘.’.
    libtoolize: copying file ‘./ltmain.sh’
    libtoolize: Consider adding ‘AC_CONFIG_MACRO_DIRS([m4])’ to configure.ac,
    libtoolize: and rerunning libtoolize and aclocal.
    libtoolize: Consider adding ‘-I m4’ to ACLOCAL_AMFLAGS in Makefile.am.
    configure.ac:18: installing ‘./ar-lib’
    configure.ac:17: installing ‘./compile’
    configure.ac:19: installing ‘./config.guess’
    configure.ac:19: installing ‘./config.sub’
    configure.ac:14: installing ‘./install-sh’
    configure.ac:14: installing ‘./missing’
    Makefile.am: installing ‘./depcomp’
    configure.ac:43: installing ‘./compile’
    configure.ac:30: installing ‘./config.guess’
    configure.ac:30: installing ‘./config.sub’
    configure.ac:41: installing ‘./install-sh’
    configure.ac:41: installing ‘./missing’
    Makefile.am:40: warning: ‘INCLUDES’ is the old name for ‘AM_CPPFLAGS’ (or ‘*_CPPFLAGS’)
    Makefile.am: installing ‘./depcomp’
    parallel-tests: installing ‘./test-driver’
    Updating version.h…
    cmp: version.h: File o directory non esistente
    È presente della nuova posta in /var/mail/root
    root@linux:/bin/bfgminer# make
    make: *** make: *** No targets specified and no makefile found. Stop.

  3. apt-get update
    apt-get install autoconf autogen libtool uthash-dev libjansson-dev libcurl4-openssl-dev libusb-dev libncurses-dev git-core –y
    apt-get install bfgminer

    All it took to get a block eruptor running on an rpi, if you’re only using one ASIC you don’t need a USB hub.

Leave a Reply

Your email address will not be published. Required fields are marked *